October 15, 2012

Oracle cluster 3.3 installation on VMware – step by step

Posted in Sun Cluster at 10:21 am by alessiodini

Finally i completed the procedure!
It was a long job, you can download it here πŸ™‚
I read it many times but i could do some error , i don’t speak fluent english . Let me know for any correction about the language or about the tasks!

Have fun with the tutorial !

Advertisements

17 Comments »

  1. Freddy said,

    Hi ….

    Its really a great job and I downloaded the PDF and tried to configure on my Toshiba C640(intel i3)…But in the last step node2 got rebooted by the node1 , but it (node1) came up with some junk errors throwing continuously on the screen..! ( “cl_comm undefined symbol”…something like that…) .. Do you have any idea about this.. I tried the same configuration on virtual box also, but same error ..!!

    Thanks
    Freddy

    • alessiodini said,

      Hi Freddy,
      thank you for download my pdf and follow my blog!
      Can your cluster boot with two nodes? Or you see everytime some reboot?
      Which Solaris 10 update did you install? Did you try to boot -x and see system logs?
      Give me more details , if you want we can work together πŸ™‚
      Alessio

      • Freddy said,

        Hi Alessio,

        Thanks for your quick reply..! actually in my previous question I mentioned node1 in bracket …but it was a typo ..it should be node2..

        Actually I couldn’t complete the cluster setup. instead it hung in the last step to reboot the other node.
        I didn’t try booting the machine in non-cluster mode as the machines are not booting in cluster mode by default…

        Details:

        Clnode1: tail /var/adm/messages
        Jul 23 00:10:53 Clnode1 genunix: [ID 935449 kern.info] ATA DMA off: disabled. Control with “atapi-cd-dma-enabled” property
        Jul 23 00:10:53 Clnode1 genunix: [ID 882269 kern.info] PIO mode 4 selected
        Jul 23 00:11:02 Clnode1 mac: [ID 736570 kern.info] NOTICE: e1000g1 unregistered
        Jul 23 00:11:02 Clnode1 mac: [ID 736570 kern.info] NOTICE: e1000g2 unregistered
        Jul 23 00:12:36 Clnode1 snmpXdmid: [ID 109133 daemon.error] Send Trap failed Return code =
        Jul 23 00:14:39 Clnode1 pseudo: [ID 129642 kern.info] pseudo-device: devinfo0
        Jul 23 00:14:39 Clnode1 genunix: [ID 936769 kern.info] devinfo0 is /pseudo/devinfo@0
        Jul 23 00:14:39 Clnode1 pcplusmp: [ID 645419 kern.warning] WARNING: Sharing vectors: pci1274,1371 instance 0 and SCI
        Jul 23 00:14:39 Clnode1 pci_pci: [ID 370704 kern.info] PCI-device: pci1274,1371@1, audioens0
        Jul 23 00:14:39 Clnode1 genunix: [ID 936769 kern.info] audioens0 is /pci@0,0/pci15ad,790@11/pci1274,1371@1
        Clnode1: more /etc/release
        Solaris 10 10/09 s10x_u8wos_08a X86
        Copyright 2009 Sun Microsystems, Inc. All Rights Reserved.
        Use is subject to license terms.
        Assembled 16 September 2009
        Clnode1:

      • alessiodini said,

        Let’s do this on skype together πŸ˜€

  2. Freddy said,

    sure ..Thanks …Please let me know the timings so that I can be available during that time…

    THanks
    Freddy

  3. Freddy said,

    Please find the system log on Clnode2….

    Clnode2: tail -50 /var/adm/messages
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘__1cOhxdoor_managerKinitialize6F_i_’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘__1cKclconf_ccrKinitialize6F_i_’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘clconf_adapter_get_ports’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘clconf_iter_get_current’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘clconf_cluster_get_nodes’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘vm_comm_handle_messages’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘__1cDccrJdirectoryH_narrow6FpnFCORBAGObject__p1_’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘__1cDrmmQreconfig_cleanup6M_v_’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘__1cVcomponent_state_proxyTunregister_from_csr6M_i_’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘__1cOcb_coordinatorVsignal_cb_coordinator6ML_v_’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘clconf_cluster_get_orb_stop_timeout’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘clconf_cluster_get_orb_step_timeout’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘clconf_cable_get_endpoint’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘__1cGnamingTnaming_context_stubP_generic_method6MrnK_FixedSeq_4CC__rnR_Ix_InterfaceSeq_4nFCORBAGObject_nJ_A_f
    ield_4n0E_Cpn0E___C6__rn0DLEnvironment__v_’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘__1cRgeneric_repl_provQregister_for_rmm6M_v_’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘__1cRgeneric_repl_prov2t6MpnHreplicaJrepl_prov_pn0BKcheckpoint_pnTckpt_handler_server_pkc9A_v_’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘__1cDrmaKinitialize6F_i_’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘clconf_obj_get_child’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘__1cDrmabEdisconnect_from_dead_primaries6MLpnCosHsystime__b_’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘clconf_obj_get_objtype’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘__1cKclconf_ccrIshutdown6F_v_’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘__1cFproxy4nGnamingTnaming_context_stub__2T5B6M_v_’
    Jul 24 00:35:05 Clnode2 genunix: [ID 819705 kern.notice] /kernel/misc/amd64/cl_comm: undefined symbol
    Jul 24 00:35:05 Clnode2 genunix: [ID 826211 kern.notice] ‘service_dbg’

    Thanks
    Freddy

    • alessiodini said,

      Hi man,
      i looked on the web and i saw some topic mentioning same situation. I suggest you to apply latest kernel patches and Cluster core patches because in my guide i did not do cos i was lazy πŸ™‚
      Let me know!
      Ale

      • Freddy said,

        Hi Aless,

        yeah..I fixed it already by downloading latest Solaris 10 ( u11) and installed the cluster and configured on virtual box. Now its running .. right now I am configuring a shared scsi storage using virtual box itself as I have only 2Gigs of RAM on my laptop , its not sufficient to run the host OS if I configured 715mb for nodes and some mem for openfiler. Will let you know the result once I configured it..

        Thanks a lot.. πŸ™‚

        Freddy

      • alessiodini said,

        Hi Freddy,
        i’m happy for you , finally you can play with it! πŸ™‚
        Let me know for anything,
        Alessio

  4. vikrant said,

    Hi Alessiodini,

    I followed the step by step approach for configuring the cluster.

    During configuration of cluster verification is getting failed. Even after that when nodes came up after reboot. I checked the status using clnode command both nodes seems running fine.

    But after some time they got reboot automatically this is happening again and again. What could be the reason for this.

    Thanks in Advance

    • alessiodini said,

      Hi,
      i’m glad you followed my procedure πŸ™‚
      Copy and paste /var/adm/messages in a website like pastebin.com and let’s see them together !
      Alessio

  5. Freddy said,

    Hi Alessio,

    How are you .. after a long time….

    Vikrant: If you try with later Solaris OS, it will work without any issue.


    Thanks
    Ranjith

    • alessiodini said,

      Hi,
      i’m good thank you! πŸ™‚

      Thank you for your reply πŸ˜€

  6. y9pp9 said,

    Hi Alessio,

    Nice to meet you

    I followed the step by step approach for configuring the cluster.
    but I can’t.

    I found that The globaldevices doesn’t mounted.
    using -G options both lofi and /globaldevices.

    Only difference is Solaris version, that is u11 than yours(u9)

    Could you find my errors?
    Thanks in Advance.

  7. Gdrta said,

    Hi Alessiodini!
    Thank you for your helpful post.
    Can you help me with my issue during testing sc in my test cluster.
    I have connected disk lun through iscsi openfiler and when Im trying create metaset disksets the openfiler iscsi disk hovered
    What Im do wrong?


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: